A versão do php 5.6 e o ​​7.0 Chegaram ao fim da vida útil no início do ano, e não estão mais recebendo correções de segurança do PHP.
Com o  cPanel e WHM dos servidores  em versão 80 migrando para a camada atual , também incentivadas para atualizar para as versões PHP suportadas no EasyApache 4.
Para ajudar nisso, estamos removendo o PHP 5.6 e 7.0 dos nossos perfis padrão do EasyApache e de todos os servidores de nuvens evitando assim ataques DDoS ao qual passamos nos dias 21 e 22/10/2019 devido a vulnerabilidades de aplicações desenvolvida em php 5.6

Essa mudança afeta os servidores que executam nossos perfis padrão do EasyApache atualmente e scripts que utilizam 5.6, mas estamos planejando remover as versões 7.0 do PHP de nossos repositórios do EasyApache 4 inteiramente pela versão 88 (prevista a partir de 27/11/2019).
Se o seu servidor estiver atualmente usando as versões 5.6 ou 7.0 do PHP, você  não  será afetado, a menos ou até que o perfil do EasyApache 4 no seu servidor seja atualizado ou reinstalado. com aplicações atualizadas.

O que isso significa para mim?
Como essas duas versões estão em fim de vida desde o início de 2019, essas versões não são mais suportadas ou recebem atualizações dos provedores de PHP. Se você está atualmente executando sites usando o PHP 5.6 ou 7.0, esta é uma boa oportunidade para incentivar uma atualização para o PHP 7.2 e suas devidas estruturas já que todas serão removidas permanentemente para a segurança dos serviços hosting e quaisquer sites que continuem a usar essas versões do PHP correm risco de possíveis problemas de segurança ou comprometimento.

Se a mudança das versões 5.6 ou 7.0 for impossível, o CloudLinux fornecerá versões atualizadas e corrigidas do PHP que chegaram ao fim da vida útil . Se o CloudLinux não for uma opção para você ou seus clientes, existe a opção de criar um perfil personalizado do EasyApache 4 e continuar usando o PHP 5.6 e 7.0, mas não o recomendamos.

Como me preparo?
Garantir que você atualizem o software para usar o PHP 7.2 (ou superior) é uma ótima maneira de começar. CMSs populares como  WordPress ,  Joomla e  Drupal  E-commerces fornecem instruções sobre como atualizar suas versões para aqueles que suportam PHP 7.2 (WordPress versão 5+, Joomla versão 3.9 e Drupal versão 8.7.1). e para plataformas de vendas online, a segurança deve falar mais alto e por este motivo estamos descontinuando todas as plataformas que usam php anteriores e agora descontinuado.

Tem alguma pergunta?
Se você não tiver certeza do que fazer a seguir ou quiser discutir mais essas mudanças, junte-se a nós em nossos  canais Slack ou  Discord ou junte-se a nós em nosso subreddit oficial do cPanel

Leia mais: https://blog.hostcuritiba.net.br/fim-da-vida-php-5-em-1o-de-janeiro-de-2019/

Leia mais: https://blog.cpanel.com/removal-of-php-5-6-and-php-7-0-in-easyapache-profiles/?fbclid=IwAR3xNsJY8ly_mvgXvhydqfvqHZVBRxL7gLMGQPIkvQsmKkbvG0lasD3C35s

« Retornar